FORUM A L'ABANDON !!!


    IGO sans GPSGate : LA solution !

    Partagez

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Mar 1 Sep 2009 - 11:01

    Suite à un post sur un autre forum, personne n'avait remarqué qu'un utilisateur avait affirmé faire tourner iGO8 sans l'aide de GPSGate !!!

    J'ai donc contacté le gars (super sympa et efficace d'ailleurs) et il a bien voulu faire quelques manips (export base de registres et fourniture de son sys.txt).
    L'intervention sur la BdR n'a rien donné mais avec son sys.txt iGO me dit qu'il a trouvé le GPS de manière automatique !!!!

    Étant actuellement dans un immeuble et comme en plus il pleut des cordes je dois attendre d'aller déjeuner (une question de minutes) pour tester en vrai !

    Je vous tiens au courant...


    By trmc at 2009-09-01


    Dernière édition par The Real Mc Coy le Mar 1 Sep 2009 - 12:43, édité 1 fois

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    Re: IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Mar 1 Sep 2009 - 12:42

    CA MARCHE !!!!!!


    By trmc at 2009-09-01

    Voici le sys.txt :
    Code:

    [project]
    name="igo8_pda"

    [device]
    type="SGH-i900"
    sdcard_dsk_num=3

    [folders]
    app="%SDCARD%/iGO8"

    [interface]
    maxzoom2d=6000000
    show_exit=1
    skin="ui_igo8"

    [rawdisplay]
    highres=0
    autoconfig=1
    driver="GDI"

    [map]
    2dheadup=1
    3d_max_tiltlevel=7800
    3d_scale_carmodel=1
    3dcarsizemin=3000
    3dcarsizemax=4500
    3dcarsizemul=10000

    [debug]
    reserve_memory=4088
    cache=358444

    Je suppose, mais ce n'est qu'une hypothèse que je n'ai pas le temps de vérifier aujourd'hui, que cela vient du paragraphe [device]...

    Ce réglage est celui pour l'Omnia qui avait ce style de pb...

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    Re: IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Mar 1 Sep 2009 - 13:10

    Hypothèse confirmée ! Si on retire la section [device] le GPS n'est plus détecté et en plus on a un soucis graphique (bande noire + clics décalés d'autant) :

    By trmc at 2009-09-01

    PS : la solution a été testée valide par un autre utilisateur Wink
    avatar
    patatozor



    Messages : 781
    Date d'inscription : 13/07/2009
    Age : 46
    Localisation : bordeaux

    Re: IGO sans GPSGate : LA solution !

    Message par patatozor le Mar 1 Sep 2009 - 13:14

    bien joué en tout cas Smile
    avatar
    LeSScro



    Messages : 1541
    Date d'inscription : 01/09/2009
    Age : 37
    Localisation : Paris/Dijon

    Re: IGO sans GPSGate : LA solution !

    Message par LeSScro le Mar 1 Sep 2009 - 14:55

    C est cool ca... en se faisant passé pour un i900... le GPS est détecté...
    C'est fort... mais bizaremment je crois qu ils ont pas la même sensibilité...
    On est 116500 et la il semblerait que l on soit en 57600... on perd en qualité de réception avec cette méthode, non ?

    Au fait, je lis plusieurs fois que vous sortez pour vos tests, vous mettez a jour les Données du GPS interne ? Car moi même, dans une cage d escalier (oh le mec du Ghetto), je capte avec 6 a 10 Sat... AmiGO 8.4.xx et Ndrive 9.xx !

    :merci:


    ----------------------------------------------

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    Re: IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Mar 1 Sep 2009 - 15:22

    Je n'ai jamais vu aucune différence entre les vitesses 57600 et le 115200 bauds. Ce sont juste des vitesses de transmission de données avec le port COM du GPS... Cela n'a normalement aucune influence (sauf peut-être si on descend trop bas en vitesse) sur la qualité de réception.

    Normalement je n'ai aucun pb pour détecter les au mini 4 sats même au milieu d'un immeuble mais à La Défense c'est compliqué quand tu bosse dans certaines tours Wink Dans la tour où je suis quand j'en capte 2 c'est déjà bien :

    By trmc at 2009-09-01

    Et oui, je mets à jour les données A-GPS (GPS Interne) mais quand tu captes VRAIMENT aucun signal sat cela ne sert à rien car cette technologie permet seulement de rendre le 1er fix à froid quasi-instantané alors que normalement tu dois télécharger ces données dans les signaux même des sats (ce qui peut prendre plusieurs minutes) Very Happy En plus, dans les signaux sat ces données n'ont une validité que de 4 heures alors qu'en A-GPS on télécharge pour une semaine...

    Oh... il faut aussi savoir que les données de navigation (dont les éphémérides) sont transmises par chaque sat à la vitesse de...

    50 bauds :siffle:

    donc on est large même avec 10 ou 12 sats en vue (info en provenance de Wikipedia).

    joaced



    Messages : 207
    Date d'inscription : 26/08/2009

    Re: IGO sans GPSGate : LA solution !

    Message par joaced le Mar 1 Sep 2009 - 17:00

    salut ca a l'air cool ta methode...au risque de paraitre un peu nul tu pourrais expliquer comment chopper igo comment l'installer et comment trafiquer tes trucs pour que le gps fonctionne sans soucis...je cherche depuis des semaines a me servir de mon tel comme gps et je n'y arrive vraiment pas je comprends rien si tu peux expliquer toutes les manips a faire depuis le debut tu me(nous) rendrais un grand service merci bps :merci:
    avatar
    LeSScro



    Messages : 1541
    Date d'inscription : 01/09/2009
    Age : 37
    Localisation : Paris/Dijon

    Re: IGO sans GPSGate : LA solution !

    Message par LeSScro le Mar 1 Sep 2009 - 17:33

    1 - tu l achetes ou tu cherches bien... Comme chez "la souris galactique"...
    2 - Tu lances le CAB, un grand classique...
    3 - Un peu de config dans le sys.txt... et ca roule tout seul...
    Le sys.txt proposé est complet pour une première utilisation

    Voila Voilou...

    @ The Real Mc Coy
    Ca c est de l info ! Merci bien pour ces précisions mais pour ma part j ai essaye avec des éphémérides perimés et avec Éphémérides a jour y a quand même une grande différence... Justement sur ce fameux Fix a froid !
    Pour le reste, étant un heureux possesseur d un P535, à l origine c est 4800 bauds, je l ai boosté a 57600 et je peux te jurer que c est plus rapide et plus précis !


    ----------------------------------------------

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    Re: IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Mer 2 Sep 2009 - 9:04

    LeSScro a écrit:
    Merci bien pour ces précisions mais pour ma part j ai essaye avec des éphémérides perimés et avec Éphémérides a jour y a quand même une grande différence... Justement sur ce fameux Fix a froid !
    Oui pour le fix à froid : il est instantané avec des données A-GPS à jour et prend plusieurs dizaines de secondes sans ou avec des données périmées... Mais quand tu ne reçois moins de 4 satellites (le minimum pour te situer en 3D même si les GPS sont capables de te situer en mode dégradé avec 3 une fois que tu as eu un 1er fix) et à fortiori si tu n'en capte aucun les éphémérides à jour ne servent à rien.

    LeSScro a écrit:
    Pour le reste, étant un heureux possesseur d un P535, à l origine c est 4800 bauds, je l ai boosté a 57600 et je peux te jurer que c est plus rapide et plus précis !
    Si tu relis ce que j'ai dit :
    The Real Mc Coy a écrit:Cela n'a normalement aucune influence (sauf peut-être si on descend trop bas en vitesse)
    Et comme 4800 c'est le minimum... il y a quand même un risque en effet à cette vitesse.
    Car il faut prendre ne compte aussi que certaines données peuvent être tronquées et donc inutilisables...

    Mon principal propos était surtout qu'entre 115200 et 57600 il ne devait pas y avoir de différence et qu'en tout cas j'ai toujours utilisé sans aucun souci la vitesse de 57600 Wink

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    Re: IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Mer 2 Sep 2009 - 9:07

    joaced a écrit:au risque de paraitre un peu nul tu pourrais expliquer comment chopper igo
    Comme l'a dit LeSScro soit tu l'achètes soit... tu te débrouilles car les méthodes illégales pour l'avoir sont interdites sur ce forum...

    Mais Google est ton ami Wink
    avatar
    LeSScro



    Messages : 1541
    Date d'inscription : 01/09/2009
    Age : 37
    Localisation : Paris/Dijon

    Re: IGO sans GPSGate : LA solution !

    Message par LeSScro le Mer 2 Sep 2009 - 11:24

    @ The Real MC Coy...
    Merci pour ces infos... je vois que tu touches en GPS !
    Very Happy


    ----------------------------------------------

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    Re: IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Mer 2 Sep 2009 - 20:30

    C'est ma spécialité Wink

    Au fait... j'ai regardé un peu comment iGO gère tout ça et notamment le [device] Very Happy
    J'aurais peut-être une surprise bientôt... ((((suspense))))

    En attendant je peux dire que iGO ne paramètre jamais le GPS à plus de 57600 bauds Wink
    avatar
    danieltecher



    Messages : 399
    Date d'inscription : 12/08/2009
    Age : 44
    Localisation : 36

    Re: IGO sans GPSGate : LA solution !

    Message par danieltecher le Jeu 3 Sep 2009 - 6:13

    Salut,

    chez moi pas moyen de faire tourner igo avec ce fichier texte, j'ai essayé plusieurs modifs, les deux premières lignes concernés me font planter igo.

    version iGo8.3.2.64873.
    skinée draghost.

    mon fichier sys d'origine contient le strict minimum utile sur le tg (avec gps gate):

    [rawdisplay]

    Screen_x=800
    Screen_y=480

    show_exit=1

    et ça tourne très bien avec gps gate, si vous pouvez m'aider pour une version "sans" Crying or Very sad
    avatar
    LeSScro



    Messages : 1541
    Date d'inscription : 01/09/2009
    Age : 37
    Localisation : Paris/Dijon

    Re: IGO sans GPSGate : LA solution !

    Message par LeSScro le Jeu 3 Sep 2009 - 6:34

    @ The real Mc Coy...
    [Suspense]
    hummmm... j adore.... :bisou:
    @ Daniel hecther...
    Tu utilises quel version du data ?


    ----------------------------------------------
    avatar
    danieltecher



    Messages : 399
    Date d'inscription : 12/08/2009
    Age : 44
    Localisation : 36

    Re: IGO sans GPSGate : LA solution !

    Message par danieltecher le Jeu 3 Sep 2009 - 6:37

    igo 8.2.6.4.873 ...?
    avatar
    jeams



    Messages : 329
    Date d'inscription : 13/07/2009
    Age : 35

    Re: IGO sans GPSGate : LA solution !

    Message par jeams le Jeu 3 Sep 2009 - 6:47

    essaye de rajouter ça :

    [interface]
    Skin="ui_igo8"
    Resolution_dir="800_480"
    Width=800
    Height=480
    show_exit=1
    Vga=1

    [rawdisplay]
    Highres=0
    Screen_x=800
    Screen_y=480

    en plus des modif' [devise]
    avatar
    LeSScro



    Messages : 1541
    Date d'inscription : 01/09/2009
    Age : 37
    Localisation : Paris/Dijon

    Re: IGO sans GPSGate : LA solution !

    Message par LeSScro le Jeu 3 Sep 2009 - 7:04

    Non mais je veux dire : v10b ou anterieur...
    car a chaque data une nouvelle modif interessante...
    regarde tes MP !
    puis essaye le tips de notre camarade... ca définit un peu mieux les accès au data !


    ----------------------------------------------
    avatar
    danieltecher



    Messages : 399
    Date d'inscription : 12/08/2009
    Age : 44
    Localisation : 36

    Re: IGO sans GPSGate : LA solution !

    Message par danieltecher le Jeu 3 Sep 2009 - 7:34

    Rien à faire, les modif ne fonctionnent pas ?..

    j'ai beau chercher et retourner le SYS.text dans tous les sens, il suffit que je rajoute ces lignes pour que ça plante.
    avatar
    danieltecher



    Messages : 399
    Date d'inscription : 12/08/2009
    Age : 44
    Localisation : 36

    Re: IGO sans GPSGate : LA solution !

    Message par danieltecher le Jeu 3 Sep 2009 - 7:44

    dans mon data/config/devices, je n'ai pas le i900, voila pourquoi ça marche pas, est ce que qu'elqu'un peut extraires le texte de ce fichier ici, afin que j'en crée un?

    Merci.
    avatar
    LeSScro



    Messages : 1541
    Date d'inscription : 01/09/2009
    Age : 37
    Localisation : Paris/Dijon

    Re: IGO sans GPSGate : LA solution !

    Message par LeSScro le Jeu 3 Sep 2009 - 8:03

    Regarde le data que je t ai envoye en MP ca devrait te sortir de l histoire...
    et au cas ou :

    Code:
    ; Please keep ABC order of sections!!!

    info_names="SAMSUNG SGH-I900"

    [gps]
    source="virtserial"

    [rawdisplay]
    driver="gdi"
    autoconfig=1
    orientation_restore=1

    [interface]
    maxzoom2d=6000000
    show_exit=1

    [registry]
    oninit1="HKCU\ControlPanel\MotionSensor\AutoOrientation:DWORD:0"
    onexitreset1="HKCU\ControlPanel\MotionSensor\AutoOrientation:DWORD"
    oninit2="HKEY_CURRENT_USER\ControlPanel\BackLight\ALCMode:DWORD:0"
    onexitreset2="HKEY_CURRENT_USER\ControlPanel\BackLight\ALCMode:DWORD"

    [power]
    backlight_key_Brightness_BA1 ="Brightness"
    backlight_key_Brightness_AC1 ="ACBrightness"
    backlight_manage_values = 1
    backlight_manage_keys = 1
    backlight_max = 12
    backlight_min = 0
    backlight_methods = 1
    backlight_events = 1
    skip_resume_process=1
    skip_suspend_process=1

    [device]
    sdcard_dsk_num=4

    Bon c est tiré d AmiGO mais c est idem a iGO 8 !
    Wink


    ----------------------------------------------
    avatar
    danieltecher



    Messages : 399
    Date d'inscription : 12/08/2009
    Age : 44
    Localisation : 36

    Re: IGO sans GPSGate : LA solution !

    Message par danieltecher le Jeu 3 Sep 2009 - 8:43

    BON...

    alors en fait j'ai modifié le fichier data que j'avais car pas de i900, et pas moyen que igo reconnaisse celui que tu m'a envoyé sscro (igo me dit qu'il manque le data, peut être pas le même format de compression, je lui ai donné le même nom mais c'est c'est pareil, si je modifie le data et que je recompresse avec winrar, igo ne le reconnait pas..., j'ai re-travaillé mon data depuis winrar directement? Rolling Eyes

    en fait j'ai crée un fichier dans data/config/device nomé TG01.ini, j'ai supprimé le superflus, celui-ci contient maintenant:

    info_names="toshiba tg01"

    [gps]
    source="virtserial"

    [registry]
    oninit1="HKCU\ControlPanel\MotionSensor\AutoOrientation:DWORD:0"
    onexitreset1="HKCU\ControlPanel\MotionSensor\AutoOrientation:DWORD"
    oninit2="HKEY_CURRENT_USER\ControlPanel\BackLight\ALCMode:DWORD:0"
    onexitreset2="HKEY_CURRENT_USER\ControlPanel\BackLight\ALCMode:DWORD"

    [power]
    backlight_key_Brightness_BA1 ="Brightness"
    backlight_key_Brightness_AC1 ="ACBrightness"
    backlight_manage_values = 1
    backlight_manage_keys = 1
    backlight_max = 12
    backlight_min = 0
    backlight_methods = 1
    backlight_events = 1
    skip_resume_process=1
    skip_suspend_process=1



    et je l'ai refermé (ajout simplement de ce fichier à l'archive) j'ai modifié aussi mon fichier SYS.txt qui est maintenant:

    [device]
    type="TG01"


    [rawdisplay]

    Screen_x=800
    Screen_y=480

    show_exit=1


    j'ai testé et ça tourne, l'important est la ligne
    "[gps]source="virtserial" à mon idee la clef de tout le mystere est ici,
    si ça se trouve on peut simplement l'intégrer au fichier sys.txt, et rien de plus à modifier, à tester...

    EDIT :ne pas oublier de paraméter le port gps du tg sur port programme 0, et ça fonctionne enfin !
    (pour moi) :merci:

    donc à faire pour ceux chez qui la manip du sys.txt ne fonctionne pas (pas de i900 dans les data)
    ou ceux qui veulent voir TG01 dans leur fichier sys.txt ... lol!


    Dernière édition par danieltecher le Sam 5 Sep 2009 - 8:01, édité 2 fois

    The Real Mc Coy



    Messages : 778
    Date d'inscription : 23/07/2009
    Age : 46
    Localisation : France

    Re: IGO sans GPSGate : LA solution !

    Message par The Real Mc Coy le Jeu 3 Sep 2009 - 20:19

    J'ai fait testé cette manip hier soir par LeSScro et ça marche... J'ai été occupé toute la journée sinon je l'aurais posté Wink

    J'ai uploadé un data.zip basé sur la dernière version disponible : http://www.steekr.com/n/50-17/share/LNK56374aa0243190c00/

    Avec ce data.zip le TG01 est détecté AUTOMATIQUEMENT sans modifier une quelconque ligne dans le SYS.TXT Very Happy

    :merci: à LeSScro pour les tests efficaces et rapides Wink

    DrJulien



    Messages : 251
    Date d'inscription : 21/08/2009
    Age : 39
    Localisation : Toulouse

    Re: IGO sans GPSGate : LA solution !

    Message par DrJulien le Jeu 3 Sep 2009 - 20:22

    Ben perso,
    avec Igo 8.3.2.64029, aucune des 2 solutions ne fonctionne.
    Je ne capte aucun signal, et Igo me dit : "récepteur GPS introuvable".
    Je ne l'ai pas testé avec gpsgate.
    D'autres ont-ils ce souci ?
    Quelle est votre version exacte de Igo 8 qui fonctionne sur vos TG01 ?
    Merci pour les informations, et bonne soirée !


    Dernière édition par DrJulien le Jeu 3 Sep 2009 - 20:25, édité 1 fois

    DrJulien



    Messages : 251
    Date d'inscription : 21/08/2009
    Age : 39
    Localisation : Toulouse

    Re: IGO sans GPSGate : LA solution !

    Message par DrJulien le Jeu 3 Sep 2009 - 20:24

    Bon, messages simultanés.
    Je vais tester ta solution avec ma version, TRMC.

    DrJulien



    Messages : 251
    Date d'inscription : 21/08/2009
    Age : 39
    Localisation : Toulouse

    Re: IGO sans GPSGate : LA solution !

    Message par DrJulien le Jeu 3 Sep 2009 - 20:40

    Ca ne fonctionne pas non plus pour moi.
    J'ai un message d'erreur qui me dit :

    Failed to open file:
    igo\400_240\loading.bmp
    exiting application.

    Quelqu'un a une idée ???

    Contenu sponsorisé

    Re: IGO sans GPSGate : LA solution !

    Message par Contenu sponsorisé


      La date/heure actuelle est Ven 14 Déc 2018 - 1:07